Gruñidos sobre …

19 abril 2009

FAQ Oracle Patch Set (Windows)

Filed under: Español, FAQ, Gruñidos, Oracle, Parches, SAP — Etiquetas: — fidelinho @ 1:25 pm

Primer post de verdad  smile-smile

Últimamente me he encontrado en los foros varias preguntas sobre el mismo tema:

Nos gustaría sabe si hay parches nuevos?
Como instalarlo?
etc.

Parece que la gente no sabe leer, no saben usar los botones de búsqueda,  incluso no siguen los enlaces o consejos proporcionados. Hay que responder (detalladamente, por supuesto) en la entrada del Foro a sus preguntas smiley-grrrrrr

Dado que en este momento SAP no soporta Oracle 11g y el “customer care suport” para 9i y anteriores ya ha finalizado, solamente hablare de 10g.

Primero hay que tener claros los números de las versiones de Oracle. Por ejemplo: 10.2.0.2.0

10 ->versión de la base de datos
2 -> “release”  de la base de datos
0 -> versión del servidor de aplicaciones
2 -> patch set
0 -> especifico de Sistema Operativo

Personalmente, hace mucho tiempo que no veo un cambio en el número especifico del sistema operativo.

Donde se pueden encontrar los patch sets y parches de Oracle?

Se pueden encontrar en Metalink, pero solamente se deben de usar los que han sido liberados por SAP. Estos se encuentran en el “Service Marketplace

smp-oracle

La Nota de SAP 871735:Current patch set for Oracle 10.2.0 tiene información del ultimo patch set liberado para 10g por parte de SAP.

En el Marketplace veo que hay 3 ficheros “bin”. Que son? que hago con ellos?

smp-oracle-ii

Que dije acerca de leer? La Nota de SAP 871735 menciona lo siguiente:

Due to their size, the Oracle patch sets cannot be provided as one piece on SAP Service Marketplace and are therefore provided with a binary split. After the download using copy /b (Windows) or using cat (Unix), the individual *.bin files must be merged again to obtain a valid zip file.
For more information, see Note 509314.

El ultimo patch set es 10.2.0.4. Yo tengo 10.2.0.1. Tengo que instalar todos los intermediarios (10.2.0.2, 10.2.0.3 y 10.2.0.4)?

No. Cada patch set contiene un fichero llamado README.html que contiene información acerca de ese patch set. Los requisitos de instalación se pueden encontrar en ese fichero. Por ejemplo, 10.2.0.4 para HPUX Itanium dice:

7 System Requirements
The following are the system requirements for this patch set:
*  Operating System: HP-UX ia64 11i v2 (11.23) or HP-UX 11.31
*  Patches:
o  PHCO_35524
o  PHSS_35979: s700_800 11.23 linker + fdp cumulative patch
Oracle Database 10g (10.2.0.1) or later

Como instalo el Patch Set?

Instrucciones detalladas vienen en el README.html. Normalmente se usa el comando “runInstaller” en UNIX y Oracle Universal Installer (setup.exe) en Windows.

Hay que instalar otros parches?

Depende. Oracle no puede liberar parches para errores individuales en Windows. Periodicamente libera colecciones de patches (tambien llamados “patch bundled”, minipatches, etc) Actualmente, el último para 10.2.0.4 Windows 32 bit es el número 15.

Si el ultimo es el 15, necesito instalar los anteriores?

La respuesta es la misma que para un patch set. Las colecciones de parches son acumulativas. Esta información está incluida en el README.html incluido en la colección.

Como instalo esa colección de parches?

Las colecciones de parches se instalan con el comando “Opatch”. Información sobre “Opach” se puede encontrar en la Nota de SAP 839182 – Oracle database 10g: OPatch

Crea un blog o un sitio web gratuitos con WordPress.com.

A %d blogueros les gusta esto: